Libre 2 Entschlüsselung

  • Hallo Zusammen,

    ich möchte nochmal auf die von Robert Berger beschriebene Methode zum nachträglichen koppeln der Bluetooth Verbindung zusammen mit der gepatchten App eingehen.

    Ich habe die APK nun bei mir mal in den Java Code decompiliert und mir den Code angesehen.

    Ich denke es wäre irgendwie möglich der App einen zweiten Patch zu verpassen bei dem die Abfrage der gespeicherten Daten bzgl. Bluetooth Verbindung unterbunden wird und bei jedem Scan die Bluetooth Verbindung neu aufgebaut wird.

    Hat sich jemand von Euch das auch schon mal angesehen?

    Dann scheint meine Theorie richtig zu sein, dass die App bei allerersten Scan ein anderes Kommando zum Verbinden nutzt als bei den späteren Scans?


    Falls du nähere Infos dazu hast, würde ich dir empfehlen, einen Thread in der Loopercommunity zu eröffnen, da sind u.a. die Entwickler von der ersten Version des Patches unterwegs.

  • Hmm, also soch innerhalb der ersten Stunde den Sensor am Handy scannen?


    Ich habs für den Sensor jetzt aufgegeben. Habe es gefühlt 100 mal mit einem Xiaomi Mi9SE versucht, ohne Erfolg. DAnn hab ich noch ein Samsung S5mini ausgegraben und es damit versucht. Das Ergebenis war unverändert: Keine Alarme, da der Sensor bereits mit einem anderen Gerät aktiviert wurde.

    Beim nächsten Sensorwechsel werde ich nochmla nen Versuch wagen.

  • Hmm, also soch innerhalb der ersten Stunde den Sensor am Handy scannen?

    Natürlich, warum länger warten? Abbott schreibt doch schon, dass man nur in der ersten Stunde ein weiteres Gerät zuordnen kann.

    Weil es Robert Berger so empfohlen hatte und die Beschränkung mit einer Stunde zum zuordnen eines weiteren Gerätes meines Wissens nach von Abbott aufgehoben wurde.

  • Hallo zusammen.....


    bei mit hat sich nun bei 2 Sensotren hintereinander nach 7 und 8 Tagen die Bluetooth-Verbindung verabschiedet. Die App sagt ...Signalverlust Alarme sind nicht verfügbar.Scannen Sie den Sensor.... Das Ausrufezeichen ist dann da. Xdrip bekommt dann logischerweise nix mehr. Es passiert ohne irgendeinen denkbaren Grund und ohne dass das Handy weiter weg war. Einfach so! Es wird keine Verbindung wieder hergestellt. Hat jemand einen Idee woran das liegen könnte? Handyneustart hab ich schon mehrfach versucht.


    Grüße

    Reinhard

  • Das hatte ich auch bei 3 Sensoren einer Charge. Bei allen ist die Bluethooth-Verbindung nach so 8-10 Tagen abgeraucht und ließ sich nicht wiederherstellen. Ich konnte den Fehler so weit eingrenzen, dass es wohl daran lag, dass die Abbott-App das Pairing nicht mehr wiederherstellen konnte. Die Sensoren haben weiterhin versucht, eine Verbindung zur Datenübermittlung herzustellen, was dann aber jedes Mal fehlschlug.


    Ich vermute, dass Abbott etwas an den Sensoren geändert hat, denn bei der letzten Charge hatte ich zwar auch schon 2x längere Bluetooth-Aussetzer, aber in beiden Fällen hat es dann nach ein paar Stunden wieder funktioniert. Ich denke, dass Abbott einen Mechanismus in die Sensoren eingebaut hat, um das Bluetooth-Pairing im Nachhinein wiederherstellen zu können, den es vorher nicht gab. Denn vorher war es bei mir so, dass die Datenübertragung sich nicht wiederherstellen ließ, wenn sie einmal dauerhaft abgebrochen war. Die letzten 4 Sensoren liefen aber auch mit Aussetzern und wiederhergestelltem Bluetooth-Pairing die vollen zwei Wochen durch. An der App kann es nicht liegen, da ich diese nicht verändert habe. Also muss es meiner Meinung nach an den Sensoren liegen.

  • Ja, kann man reklamieren. Als ich einmal nach dem Start zwar scannen, aber nicht verbinden konnte, hab ich den Kundendienst angerufen und die haben einen neuen Sensor geschickt. Funktionierender Alarm ist eine zugesicherte Eigenschaft.


    Den alten Sensor konnte ich zwar mit einer Neuinstallation der App reaktivieren, aber nach ein paar Tagen brach die Verbindung wieder dauerhaft ab. Denke auch, dass es am Sensor lag.

  • Hi,

    in der aktuellen Diabetes Journal Ausgabe stand was dazu drin. Die zweier Sensoren haben wohl irgendeinen Schutz drin, der auch bei zu starken Zuckerschwankungen irgendwas abstellt und damit nicht mehr funktionieren. Bin mir aber gerade nicht sicher, ob nur Bluetooth oder der komplette Sensor dann abgeschaltet wird.

    Daher wird dieser Schutz wieder entfernt und betroffenen Sensoren können über die Hotline ersetzt werden.

  • BT aus: Eine meckernde LibreLink-App (gepatcht oder nicht dürfte egal sein) ist einem gewiss.

    Was mir erst heute aufgefallen ist - ich benutze mein Smartphone eben kaum zum Telefonieren - : Wenn ich jemanden anrufen will, kommt im Moment es Hörerabhebens die Meldung, dass Alarme nicht möglich sind. Nach dem Auflegen ist wieder alles schick. Ist das ein generelles Problem, oder hat mein bejahrtes OPO doch noch eine ganz besondere Meise? Kann die LL-App womöglich nur nicht damit umgehen, dass der Audiofokus umgesetzt wird? (Mit einer Musikabspielapp kann ich das nicht reproduzieren.)

  • so, 2. Sensor läuft - alles schick. Sicherheitshalber habe ich beim starten und beim 1. scannen GPS mit eingeschaltet, ist jetzt aber wieder aus.


    SG 55, BZ 116 - na ja... geben wir ihm noch ein paar Stunden :rofl

  • kommt im Moment es Hörerabhebens die Meldung, dass Alarme nicht möglich sind.


    das ist eine Einstellung (ich glaub aber in xDrip), dass man die Alarme während des Telefonieren aussetzt

    Nur blöd, dass die Meldung von LibreLink kommt (und das weiß von xDrip erst mal nichts - und dort ist das nicht aktiviert, mich ruft doch eh keiner an...) - eingeschaltet ist auch nur der Signalverlust-Alarm (der letzte der drei). Dasselbe passiert aber auch, wenn stattdessen nur der High-Alarm aktiviert ist. Gleiches Verhalten wie beim Abschalten von BT. (An der an xDrip hängenden Smartwatch liegt es hoffentlich nicht?)