Verbindung bricht ab gepatchte Libre App

  • Moin,

    Mein Name ist Torsten bin 39 Jahre alt

    Und habe vor ca. 2 Monaten die Diagnose Diabetes Typ 1 erhalten .

    Habe mich bisher ganz gut eingelebt.

    Als Messgerät benutze ich den Freestylelibre 2

    mit der gepatchten App und Xdrip+ Was auch super funktioniert.

    Ich habe nur ein Problem jede Nacht um ca. 4 Uhr bricht die Verbindung ab und es werden keine Daten mehr empfangen.

    Hab schon alle möglichen Einstellungen probiert aber immer das selbe Ergebnis.

    Als Handy nutze ich das Samsung S10


    Wäre super wenn einer eine Lösung für mich hätte !

    Vielen Dank schonmal !

  • Willkommen im Forum, Torsten!


    Ich habe einen Samsung S 10e mit Android 11, und darauf läuft alles seit mehr als einem Jahr problemlos, auch nachts. Dein Problem hört sich prinzipiell an, wie vom Energiemanagement verursacht. Hier sind mal meine Akkueinstellungen:


       


    Was ich noch gemacht habe, ist die Apps xDrip und Libre Link zu sperren. Das bewirkt, wenn man auf „alle schließen“ tippt, dass diese Apps nicht beendet werden. Möglicherweise verhindert das Sperren auch, dass die Apps im Hintergrund in den Ruhemodus versetzt werden.


    Am Samsung sperrt man eine App, indem man in der Anzeige der aktiven Apps (III-Taste) lange oben auf das Logo der App drückt, dann erscheint folgendes Kontext-Menü. Darin auf „diese App sperren“ tippen, dann erscheint das Schloss-Symbol unten rechts an der App.



    Ungewöhnlich ist allerdings, dass das bei dir immer exakt um 4:00 Uhr passiert. Ist das wirklich so regelmäßig? Dann schaltet sich vielleicht um 4:00 Uhr am Handy oder in dessen Umfeld etwas ein, was LibreLink bzw. die Verbindung stört. Ich habe z.B. den Geräteschutz in der Gerätewartung (Virenscanner) bewusst nicht aktiviert. Oder schau mal nach, was dein Router um 4:00 Uhr nachts macht. Vielleicht kappt der das WLAN immer um dieselbe Uhrzeit und deshalb wird LibreLink im Hintergrund beendet?

    Einmal editiert, zuletzt von Kappa ()

  • Das ging ja schnell mit einer Antwort.

    Also mit dem Router müsste alles i.o. sein der Fehler tritt auch auf wenn ich unterwegs bin.

    Muss also, denke ich am Handy oder irgendeiner Einstellung liegen .

    Habe mal alles eingestellt wie bei dir .

    Werde morgen mal berichten was über Nacht passiert ist .Hier nochmal zwei Screenshots von xdrip.

    Immer kurz nach 4 Uhr Nachts bricht die Verbindung ab und in der Librelinkapp wird auch das Ausrufezeichen angezeigt das keine Alarme verfügbar sind .

    Erst wenn der Sensor neu gescannt wurde funktioniert wieder alles.

  • Ich habe mehrfach gelesen, dass Playprotect (?) immer um die gleiche Uhrzeit die Apps stoppt, die nicht aus dem Playstore kommen. Das deaktiveren soll helfen.

    Da ich das Problem noch nicht hatte, kann ich leider keine genaueren Infos dazu geben.

    LG Kris

    LibreLink (Android)

    AAPS (Android)

    SmartWatch - Miband 4

    Meß-Eisen - Freestyle Libre 1

    Smartphone - Xiaomi Mi9 (Android 10)

  • Die Verbindung ist heute wieder kurz nach 4 abgebrochen.


    Laut Playprotect wurden alle Apps kurz nach 4 gescannt.

    Das könnte der Fehler sein hab es jetzt mal ausgeschaltet.

    Morgen gibt's Infos.


    Danke für die ganzen Tips

  • Moin,

    Leider hat das ausschalten von Playprotect nichts gebracht.

    Hat noch einer einen Tip ?

    Ansonsten werde ich beim nächsten Sensor wechsel mal das Handy zurücksetzen und alles neu installieren.

  • Moin,

    Leider hat das ausschalten von Playprotect nichts gebracht.

    Hat noch einer einen Tip ?

    Ansonsten werde ich beim nächsten Sensor wechsel mal das Handy zurücksetzen und alles neu installieren.

    Du hast ja vor kurzem alles erst installiert. Wie hast du das eigentlich gemacht. Normalerweise soll/muss man ja erst mal die Original Libre Link installieren und wieder deinstallieren. Andere bekamen beim Start der gepatchten App die Meldung: installieren sie die App aus dem Playstore, weil die Originale 2.3 aus einer anderen Quelle stammte und es lief nicht. War das bei dir nicht so?


    Ich frag mich nämlich, was man derzeit noch machen kann, falls man mal zurück setzen müsste. Am besten hält man ein Komplettbackup in Google Drive vor.

  • Ich hatte erst 2 Wochen die original App und hab dann umgestellt auf die gepatchte App und xdrip.

    Ne Meldung das ich die original App aus den Playstore installieren soll hab ich nicht bekommen .


    Bei der original App gab es keine Probleme

  • Ich stehe grad vor der gleichen Überlegung mit meinem neuen Android 11 Handy dies auch so zu probieren.


    Du hast also die Libre App aus dem Playstore installiert, dann deinstalliert und dann die gepatchte 2.3er Version installiert?

    Bei meinen bisherigen Versuchen, im Anschluss dann die gepatchte App zu installieren, werden mir nämlich auch keine Fehlermeldungen angezeigt.


    Aktuell läuft bei mir alles noch auf dem bisherigen Android 9 Handy. Beim nächsten Sensorwechsel würde ich dann auf das neue Handy umsteigen wollen. Daher die "Trockenübungen" ...

  • Ich habe ein Xiaomi mit A11 und die Installation ging auch ohne Probleme

    Also scheint es mir so, dass die Vorgehensweise (Libre App aus dem Playstore installieren und deinstallieren, danach die gepachte (ältere) Libre 2.3er Version aufspielen, aktuell auch noch so funktioniert

    Zumindest bei Samsung und Xiaomi mit A11.

  • Ähm nicht ganz. Ich habe die gepatchte app direkt installiert. Das original war hier nie drauf

    Das habe ich auch in der Looper Community gelesen. Dort berichtete jemand, dass er auf mehreren Handys die Original-App nicht benötigte. Andere haben dem aber vehement widersprochen. Deshalb scheint es irgendwie mit der Handy-Marke bzw. der entsprechenden Android-Variante zu tun zu haben.

  • Irgendwie bin ich doch ganz froh, dass meine Smartphones gerootet sind, da ist eine Wiederherstellung der App mit Daten unproblematisch.

    Was mir allerdings Sorgen bereitet, ist das Wachstum der Datenbank von LL :-(

  • Also, woran merke ich denn jetzt, dass es nicht funktioniert....


    1. Ich installiere die Original Libre App, deinstalliere sie wieder und installiere dann die gepachte Libre App. Wenn keine Fehlermeldung kommt, heißt dann etwa: Es funktioniert.... ?


    2. Ich installiere gleich die gepachte Libre App ohne Fehlermeldung?


    3. Oder merke ich das dann etwa erst, wenn ich den neuen Libre mit der App scanne und die Daten werden nicht permanent an Xdrip+ übertragen/angezeigt?


    Ich bin jetzt etwas verwirrt.... 🤪